The Hornshoppe Forum
February 17, 2019, 11:06:56 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: SMF - Just Installed!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: My Spectral DMA50 Amp  (Read 325 times)
vrod
Newbie
*
Posts: 25


View Profile
« on: January 25, 2019, 06:26:44 PM »

I've noticed recently a low hum coming from my Spectral Amp.They are hooked up to my The Truth preamp. Both speakers are totally silent and there is no degrading of the sound out of the attached speaker to that amp. I have two DMA50's in bridged mode. Any advice?
Logged
Henry
Hero Member
*****
Posts: 908


View Profile
« Reply #1 on: January 26, 2019, 07:40:26 AM »

I'd check the amp's DC offset first, then swap some signal and power cords.  It could just be as simple as a ground wire from the source to the amp.

My cat has one talent: pulling wire.  I always have to check connectors before playing music.
Logged
vrod
Newbie
*
Posts: 25


View Profile
« Reply #2 on: January 26, 2019, 09:35:12 AM »

Thanks Henry, how do you do this and  (check DC offset )?
Logged
Steve F
Sr. Member
****
Posts: 425


View Profile Email
« Reply #3 on: January 26, 2019, 08:09:22 PM »

Is the noise coming through the speakers, or is a mechanical noise from the amps themselves?
Logged
Steve F
Sr. Member
****
Posts: 425


View Profile Email
« Reply #4 on: January 26, 2019, 08:14:34 PM »

Check dc offset

https://m.wikihow.com/Measure-DC-Offset
Logged
Ed Schilling
Administrator
Hero Member
*****
Posts: 1360


View Profile Email
« Reply #5 on: January 26, 2019, 09:39:19 PM »

Vrod, From your post it seems that it must be mechanical hum from inside the unit if the speakers are silent. That may or may not be hard to "fix". If it is coming from the amp itself and not the speakers then pull the top and listen.......
Ed
Logged
Steve F
Sr. Member
****
Posts: 425


View Profile Email
« Reply #6 on: January 27, 2019, 12:16:19 PM »

That’s what I’m wondering Ed. Sometimes transformers need to be tightened up.
steve
Logged
vrod
Newbie
*
Posts: 25


View Profile
« Reply #7 on: February 03, 2019, 07:16:48 AM »

Steve, the noise is coming from the amp, not the speakers.
Logged
vrod
Newbie
*
Posts: 25


View Profile
« Reply #8 on: February 03, 2019, 07:29:53 AM »

To everyone who has helped, is it possible for transformer coils to hum and not the transformer housing itself? Do they get loose  or vibrate? Does this mean the transformer will fail?
Logged
Ed Schilling
Administrator
Hero Member
*****
Posts: 1360


View Profile Email
« Reply #9 on: February 04, 2019, 11:45:52 PM »

VRod, yes, the windings and laminates can vibrate inside the case. It does not mean it will fail. Can be a bitch if even possible to eliminate,
Ed
Logged
Steve F
Sr. Member
****
Posts: 425


View Profile Email
« Reply #10 on: February 05, 2019, 10:19:44 PM »

I’ve quieted transformer hum by first making sure the laminates were tight, then checking the chassis mounts. I got lucky in that nothing happened to the windings themselves. Perhaps high temperature epoxy could be step three. Ed’s right though. It can be difficult to solve.

steve
Logged
Ed Schilling
Administrator
Hero Member
*****
Posts: 1360


View Profile Email
« Reply #11 on: February 11, 2019, 07:11:10 PM »

Victor, on old Magnavox TV's the Yoke (an xformer on the tube) would rattle. It was a common problem and drove people crazy. We fixed most by wedging toothpicks and shit in them. Stuff like hot glue and silicone had no effect.

I spoke with Don and he said it is possible something in the p/s is dying and could be causing them to hum. He doubts this is the case but it could be. He said if you can put pressure on them or squeeze them and the hum stops then it's probably just mechanical. If not he said you may want to have them checked out or just wait and see what happens.
Ed
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!