The Hornshoppe Forum
June 27, 2017, 12:00:34 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: SMF - Just Installed!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Amp Camp Amp (ACA) PSU...  (Read 2521 times)
hapinoregon
Newbie
*
Posts: 9


View Profile Email
« on: March 22, 2015, 07:12:35 PM »

I need recommendations for a source to buy a pair of PSUs for Amp Camp Amps, please.

Brands, voltage/amperage, etc. recommendations are also needed and appreciated.

MTIA
Logged
Ed Schilling
Administrator
Hero Member
*****
Posts: 1294


View Profile Email
« Reply #1 on: March 23, 2015, 11:12:09 AM »

Hap, E Bay is your friend. They are 19volt ~3 amp computer supplies. Mine are 19V@ 3.42 amp. The 19V is important and anything around 3 amps will be fine.

There will be tons on E Bay. The trick is figuring out the size of the jack! If you have and I doubt it, a Rat Shack nearby you could take the amp there and ask the guys to figure out what size fits it, get the metric number NOT just a "letter type", actual size will be on the back of the pkg. or maybe the front. It will be a common size and then you can find the correct supply with the correct plug on E Pay.

The ones I use for the jacks and plugs are 5.5 X 2.1mm but they are not what comes from DIY and I do not know the size they use, I just know the supply they supply will not fit the jacks I used for my scratch built ones.

If you sent the correct plugs and the p/s (if they did not fit) I'll be happy to replace the ends with your plugs....cover the shipping.

What happened to the original supplies?

You do need those amps running!
Ed
Logged
hapinoregon
Newbie
*
Posts: 9


View Profile Email
« Reply #2 on: May 07, 2015, 05:04:57 PM »

Hey, Ed,

Sorry for taking so long to reply, but laot going on, some ok, some not...

Anyway, a query to diyaudio's Pass Labs forums yielded the info that the power tip for the kit is 5.5 x 2.5. Found a pair on eBay for <$20 including shipping. Look like the ones that disappeared when we packed up the "entertainment" room for painting. Found the amps ok, but a gremlin musta wanted the PSUs. Nowhere to be found...

Next: I have a decided hum coming from my Truth's right channel. It seems to be in the volume control as I can get slight variations in the loudness of the hum jiggling the volume control knob. Otherwise, the hum is an annoyingly loud constant.

May I box it up and send it to Papa for ministering and healing?

MTIA

Harry
Logged
Ed Schilling
Administrator
Hero Member
*****
Posts: 1294


View Profile Email
« Reply #3 on: May 07, 2015, 08:42:19 PM »

You should have already had it on the way! The volume control should not be able to cause any issues due to the way it works.....but I believe you! Make sure your cables are good.....they are a more likely source, I just had a ground on an IC fail, drove me crazy for a little while! Was intermittent.....
Ed
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!